Wednesday, May 21, 2008

upgrading zlib

I have to upgrade my zlib to version 1.2.3 to upgrade clamav 0.93. If you have recent version (after July 18,2005), you might have it installed already. For older distros, upgrade is a must to avoid security vulnerabilities in 1.2.1 and 1.2.2. You can download the source code here :

Install from source.
1. unpack the source : tar xzvf zlib-1.2.3.tar.gz
2. change to source dir: cd zlib-1.2.3
3. configure it: ./configure --shared --prefix=/usr
4. 'make' it: make
5. install it: make install (this will install the library in dir /usr)

Extra check:
1. Go to /usr/lib and check whether symbolic links are ok :
[root@proxy lib]# ls -l libz*
lrwxrwxrwx 1 root root 13 May 16 06:29 ->*
lrwxrwxrwx 1 root root 13 May 16 06:29 ->*
-rwxr-xr-x 1 root root 82305 May 16 06:29*

If old libraries are still lying around or and point to old library e.g ->, delete them.

That's all there is to it.

zlib home

1 comment:

Tucowed said...

thank you Zamri!